ST-helpers

Site d'entre-aides pour les logiciels surfacique en FRANCAIS
 
AccueilFAQRechercherS'enregistrerMembresGroupesConnexion

Partagez | 
 

 rendu failed????

Aller en bas 
AuteurMessage
gbaillot
Baby Studio
avatar

Nombre de messages : 46
Age : 36
Localisation : Sur genéve (versoix)
Date d'inscription : 12/07/2006

MessageSujet: rendu failed????   Ven 11 Aoû - 15:46

Bonjours a tous, j'ai plusieur pb en ce moment sur studio, g souvent des rendus failed ( souvent sur des gros fichier)ou alors il y a certains rendus qui marche avec une tolérance du mm mais qui est failed avec une tolérance plus petite (mais pk?????????????) Question Y a t'il une limite de taille de fichier au dela du quelle studio ne peu plus calculer de rendu??. J'aimerai savoir si qq connais une réponse ou des techniques pour y remedier, deplus g depuis peu un bi proc mais impossible d'envoyer un calcul de rendu sur les 2 proc en meme temps, y a t'il une config particuliere a programmer pour lancer le calcul sur les 2 proc en meme temps (g beau essayer de calculer en powertraceur, rien y fait!!). Merci a tous pas avance de votre aide

Pour info les fichier sur lequelle je travaille son trés trés gros (entre 3 a 80 MO),meme aprés retouche de surface pour alleger le fichier, car se sont en générale des fichier igs ou step que je recuper. Deplus il y beaucoup de diamants donc enorment de surfaces ( compter 61 surfaces par diamant donc multiplier par 100,200 ou 300 diamant cela monte vite en taille de fichier). G vraiment besoin d'aide HELP
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Chewie
Multi Spans
avatar

Nombre de messages : 134
Age : 41
Localisation : Vélizy
Date d'inscription : 24/08/2005

MessageSujet: Re: rendu failed????   Ven 11 Aoû - 16:56

un des probleme recurrent sur studio, c qu'il tient compte de toutes les surfaces pour calculer un rendu, même celles invisble a l'écran, nettoie bien ton fichier de tous ce qui est inutile, surfaces, courbes,etc...., péte l'historique, mets toutes tes surfaces en single sided, inverse les normal si nécessaire, pas de mesh tolerance inférieur a 0,025 (cm), une chose aussi quitte a me répéter, lorsque on mets le global quality level en high, baisser les paramétres ne sert a rien, studio n'en tient pas compte, il faut se mettre en low et augmenter tes parametres : mesh tolerance : 0.025, anti aliasing min 4, max 8, reflection 3, refraction 5, shadows 3. aller bon courage

edit: le level de refraction s'ajuste en fonction du nombre de surfaces transparentes que la lumiére doit traverser +1, exemples 1vitre dont on a modelisé l'epaisseur, 2 surfaces a l'aller, 2 au retour +1 = 5, pour ton pb de biproc je suis pas un expert, je ne puis t'aider sorry
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gbaillot
Baby Studio
avatar

Nombre de messages : 46
Age : 36
Localisation : Sur genéve (versoix)
Date d'inscription : 12/07/2006

MessageSujet: Re: rendu failed????   Ven 11 Aoû - 17:21

merci pour toutes c astuces que je ne connaissais pas mais je ne voi pas comment mettre mes surfaces en single side rapidement car je doit avoir plus de 10000 surfaces alors je me vois mal les mettre une a une depuis le render stat et verifier en plus la normal de chaque.Mais merci quand meme.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Chewie
Multi Spans
avatar

Nombre de messages : 134
Age : 41
Localisation : Vélizy
Date d'inscription : 24/08/2005

MessageSujet: Re: rendu failed????   Ven 11 Aoû - 17:27

pour mettre toutes surfaces en single sided, tu les sélectionnes toutes, et dans render stat et tu utilise select all rows pour changer un parametres sur toutes les surfaces en même temps, et pour unifier tes normales soit tu utilise "unify", ou tu les stitche puis les destitche juste aprés ça mets toutes les normales dans le même sens
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gbaillot
Baby Studio
avatar

Nombre de messages : 46
Age : 36
Localisation : Sur genéve (versoix)
Date d'inscription : 12/07/2006

MessageSujet: Re: rendu failed????   Ven 11 Aoû - 17:34

merci mais je ne trouve pas le unify il se trouve ou dans studio ce parametre la??
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Chewie
Multi Spans
avatar

Nombre de messages : 134
Age : 41
Localisation : Vélizy
Date d'inscription : 24/08/2005

MessageSujet: Re: rendu failed????   Ven 11 Aoû - 17:36

dans object edit il est caché derriére le reverse normal
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
gbaillot
Baby Studio
avatar

Nombre de messages : 46
Age : 36
Localisation : Sur genéve (versoix)
Date d'inscription : 12/07/2006

MessageSujet: Re: rendu failed????   Ven 11 Aoû - 17:58

Merci pour ce que tu vient de m'apprendre aujourd'hui mais malheuresement pour moi ca ne marche toujours pas et je pense que ca vient du fichier qui est vraiment trop gros malgrés tout ce que tu ma conseiller de faire ( virer les surface que l'on ne vois pas , mettre les surfaces en single side, regler les parametre de rendu....) ARFFFFFFF je suis vert de chez vert alien je sais pas comment je vais gerer tout ca thumright . En tout cas merci beaucoup maitre jedi lool.
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Braman
Rang: Administrateur
avatar

Nombre de messages : 862
Age : 37
Localisation : Colombes
Date d'inscription : 15/09/2004

MessageSujet: Re: rendu failed????   Sam 12 Aoû - 17:17

Chewie à raison avant de faire du rendu sur studio le nettoyage du fichier est impératif....Petit truc en plus pour le nettoyage de fichiers : effectue un "delete null nodes" que tu trouveras dans le menu delete (ca efface tous les nodes vides que tu peux voir dans le SBD) ; deuxieme chose...si tu bosses sur la version treize il y a un nouvel outil qui s'appelle "check" que tu viens parametrer en fonction de ce que tu recherches...et notamment une option permettant de détecter les surfaces en double !!!!! plutôt pratique car même si tu crois n'avoir aucunes surfaces en double il t'en trouve Wink ; derniere petite chose en ce qui concerne les normals...depuis la version 13 lorsque tu enclenche le diagnostic shading de couleur (le bleu) et que tu deplois les options ..une case "reverse normal" apparait et ne demande qu'a etre cochée.....elle sert a mettre dans une couleur differente toutes les surfaces qui ont les normales inversées !!!! Apres il ne te reste plus qu'a toutes les sélectionnées puis a éffectuer un "check normals" et de cliquez sur "reverse all"

Voili voilou je prépare des screens shots de tout ça une fois que j'aurais finit de réinstaller mon PC (changement de disque dur)
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bbrplace.fr
gbaillot
Baby Studio
avatar

Nombre de messages : 46
Age : 36
Localisation : Sur genéve (versoix)
Date d'inscription : 12/07/2006

MessageSujet: Re: rendu failed????   Lun 14 Aoû - 18:23

merci braman mais je ne trouve pas ton outil magique "check" dans la version 13 alors si tu pouvais m'indiquer son emplacement ce serait super cool. Merci d'avance
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Braman
Rang: Administrateur
avatar

Nombre de messages : 862
Age : 37
Localisation : Colombes
Date d'inscription : 15/09/2004

MessageSujet: Re: rendu failed????   Mar 15 Aoû - 1:18

Voili voilou




Attention vérifie ta modélisation par petit bout et mettant en invisible tout ce que tu ne veux pas vérifier (la fonction vérifie tout ce qui est visible).

Autres choses que j'ai oublié de parler...si tu as passé des rounds automatics sur ta model il se peux qu'il y en ai qui soit partit en sucette (style un pole qui se barre vers l'infinit) c'est vicieux ca ne se voit pas pas mais ca peut poser aussi ce problème de render failed...pour ce qui est des normals de surfaces pour que le rendu ne les prennes que dans un seul sens il faut que tu selectionnes tes surface que tu ailles dans le render stats (que tu trouves dans render/editors) et que tu décoches double sided.

Voili voilou apres tout ça y'a plus de problèmes...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bbrplace.fr
maitre yoda



Nombre de messages : 5
Date d'inscription : 27/05/2009

MessageSujet: Re: rendu failed????   Mer 27 Mai - 21:49

"mode deterrage de post on"

en fait, ce problème est présent lorsque tu importes des fichiers issus de différents logiciels, ou tu mélanges du *.step, de l'iges et du wire par exemple.

outre detruire l'historique, dégrouper tout ce qui peut l'etre, unstitcher, delete null nodes, shrink to trim, et zero transform, nettoyer la sbd, utiliser vcheck pour vérifier les doublons, petites surfaces, virer tout ce qui est inutile, il n'y a plus de soucis après, ca fonctionne.... j'ai eule cas avec des fichiers de 150mo avec des surfaces minuscules et des diamants aussi....
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Braman
Rang: Administrateur
avatar

Nombre de messages : 862
Age : 37
Localisation : Colombes
Date d'inscription : 15/09/2004

MessageSujet: Re: rendu failed????   Mer 27 Mai - 22:53

Bienvenue Maitre Yoda

Tu nous sort la grosse artillerie lourde pour nettoyer ton fichier (en même temps si il n'y a plus d'autres solutions...)

Tiens j'ai une question pour toi : lorsque je faisais des rendus il m'est arrivé d'avoir un "render failed" lorsque j'appliquais une texture sur un de mes shaders (sans textures tout fonctionne et il suffit de mettre une texture (même celle de studio !!) et de relancer un rendu pour que celui-ci plante..un ptite idée ?
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bbrplace.fr
Raph
Junior Studio


Nombre de messages : 63
Date d'inscription : 20/05/2005

MessageSujet: Re: rendu failed????   Jeu 28 Mai - 10:56

Pour les textures, le problème vient souvent des images insérées (embedded en English sous Alias) quand tu sauves ton fichier.
Une fois réouvert, alias recharge mal les images, pourquoi je n'en sais rien, peut être je fais une mauvaise manip.

Mon astuce est d'extraire les images references (File > images references > Extract images references) et de les recharger si cela n'a pas suffit.

Je suis pas très clair dans mon explication, mais peut être cela répond à ton problème!
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
maitre yoda



Nombre de messages : 5
Date d'inscription : 27/05/2009

MessageSujet: Re: rendu failed????   Jeu 28 Mai - 16:32

Raph à trés bien saisi le problème et j'avoue, que c'est un sujet que je n'ai pas abordé régulièrement.

Concernant le problème de départ, il s'agit en fait de faire une remise à plat de tous les éléments présents dans le fichier, certains étant des éléments issus de studio, d'autres de volumiques, etc.

Il est, après, bien evidemment possible de regrouper les objets par entités, malgré avoir tout dégroupé auparavant, il suffit d'avoir pris soin d'avoir assigné des textures ces entités, et hop, le tour est joué...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Braman
Rang: Administrateur
avatar

Nombre de messages : 862
Age : 37
Localisation : Colombes
Date d'inscription : 15/09/2004

MessageSujet: Re: rendu failed????   Ven 29 Mai - 9:05

Ok..merci pour ces réponses d'expert Wink
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bbrplace.fr
Raph
Junior Studio


Nombre de messages : 63
Date d'inscription : 20/05/2005

MessageSujet: Re: rendu failed????   Ven 29 Mai - 9:58

Merci pour le qualitatif d'expert Very Happy
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Contenu sponsorisé




MessageSujet: Re: rendu failed????   

Revenir en haut Aller en bas
 
rendu failed????
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» test de rendu render(in)
» rendu intérieur maison
» 1er rendu Artlantis 1.2
» question rendu avec blender...
» 3ème rendu

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
ST-helpers :: Les forums Studio Tools :: Rendu-
Sauter vers: